Kvm.la http://www.kvm.la/ zh-CN I'm alive, I'm here! 人生的两大悲剧:想要的没得到和想要的得到了。 Mon, 15 Apr 2019 13:10:00 +0000 Mon, 15 Apr 2019 13:10:00 +0000 众所周知 http://www.kvm.la/1073.html http://www.kvm.la/1073.html Mon, 15 Apr 2019 13:10:00 +0000 YY.K 最近几年的一些营销号和自媒体的视频和文章都特别+非常+特别非常喜欢带上“众所周知”。      

一些特点 视频内容多数是东拼西凑出来的或者搬运过来重新配音并打上LOGO,

常用语 “众所周知” “小伙伴们怎么看?” “各位网友怎么看” “各位网友如何如何”

文稿内容只要能看到“众所周知”可以判断100%是自媒体营销号,然后通篇内容就是视频配音读稿的文案一字不改直接发出来,有时候看着看着都能自动脑补BGM。

还有一类更恶劣的,直接看图编内容,东拼西凑出来狗屁不通的洗稿见闻内容。

这拨人给人的感觉好像都是一个窝里面的, 和UC震惊部一样一样的,不知道啥时候才是头,这些想蟑螂的傻逼才会死翘翘进垃圾桶。


]]>
0 http://www.kvm.la/1073.html#comments http://www.kvm.la/feed/1073.html
永隆银行的路由/银行/分行号 http://www.kvm.la/1072.html http://www.kvm.la/1072.html Fri, 12 Apr 2019 10:47:49 +0000 YY.K 银行名/Bank Name : CMB Wing Lung Bank Hong Kong

银行编号/Bank Code : 020

SWIFT Code / BIC : WUBAHKHH

分行编号/Branch Code : 601

地址/Bank Address: WING LUNG BANK BUILDING, FLOOR 3, 45 DES VOEUX ROAD, CENTRAL

城市/City : HONG KONG


]]>
0 http://www.kvm.la/1072.html#comments http://www.kvm.la/feed/1072.html
Centos7下通过grub2引导进行网络自动重装系统 http://www.kvm.la/1071.html http://www.kvm.la/1071.html Fri, 15 Mar 2019 07:07:00 +0000 YY.K Shell大致流程

1.获取网络IP配置参数

2.写入自定义grub引导内核

 2.1 http://103.xxx.xxx.xxx/kickstart.php/rh?end=1&ethworkaround=1是预设定的anaconda-ks自动响应安装脚本。
3.修改grub默认配置参数等待时间和指定引导顺序。

4. 重新生成grub2配置

5.重启等待安装完成。

最后建议在NoVNC或者IPMi辅助的情况下使用。

vmlinuz的网络参数还有一种写法是 ip=address::gateway:netmask:hostname:interface:method

getETH=`ip -4 route list 0/0 |awk '{ print $5 }'`
getGATEWAY=`ip -4 route list 0/0 |awk '{ print $3 }'`
getNETMASK=`ifconfig $getETH | awk '/mask /{ print $4;}'`
getIPADDR=`ifconfig $getETH | awk '/inet /{ print $2;}'`

cat>>/etc/grub.d/40_custom<<EOF
menuentry 'Netinstall' {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod xfs
set root='hd0,gpt2'
linux16 /vmlinuz ro ks='http://103.xxx.xxx.xxx/kickstart.php/rh?end=1&ethworkaround=1' net.ifnames=0 biosdevname=0 crashkernel=auto gateway=$getGATEWAY ip=$getIPADDR nameserver=8.8.8.8 ksdevice=$getETH  netmask=$getNETMASK
initrd16 /initrd.img
}
EOF
 sed -i 's/GRUB_TIMEOUT=5/GRUB_TIMEOUT=60/g'  /etc/default/grub
 sed -i 's/GRUB_DEFAULT=saved/GRUB_DEFAULT=Netinstall/g'  /etc/default/grub
 grub2-mkconfig --output=/boot/grub2/grub.cfg
 reboot
]]>
0 http://www.kvm.la/1071.html#comments http://www.kvm.la/feed/1071.html
RouterOS导入key登陆ssh http://www.kvm.la/1070.html http://www.kvm.la/1070.html Thu, 31 Jan 2019 15:27:00 +0000 YY.K Linux或者Mac OS生成一个key

ssh-keygen -t rsa

用scp上传到Mikrotik

scp -P端口 ~/.ssh/id_rsa.pub admin@10.0.100.1:id_rsa.pub

在Mikrotik内导入key

[admin@MikroTik] > /user ssh-keys import public-key-file=id_rsa.pub user=admin

打印查看

[admin@MikroTik] > /user ssh-keys print
Flags: R - RSA, D - DSA        
 #   USER                       BITS KEY-OWNER        
 0 R admin                      2048 XXXXXXX
]]>
1 http://www.kvm.la/1070.html#comments http://www.kvm.la/feed/1070.html
ipmitool获取mac地址 http://www.kvm.la/1069.html http://www.kvm.la/1069.html Thu, 31 Jan 2019 11:00:51 +0000 YY.K 抓取主板第一个网卡mac地址

ipmitool  raw 0x30 0x21 | tail -c 18 |sed 's/ /:/g'

抓取BMC网口mac地址

ipmitool raw 0x0c 0x02 0x01 0x05 0x00 0x00|tail -c18| sed 's/ /:/g'
or
ipmitool lan print | grep "MAC Address" |tail -c18
]]>
0 http://www.kvm.la/1069.html#comments http://www.kvm.la/feed/1069.html
转载:How To Connect To Cisco Devices Via Serial Port Using GNU/Linux http://www.kvm.la/1068.html http://www.kvm.la/1068.html Thu, 31 Jan 2019 05:06:00 +0000 YY.K 原文链接 :https://acidborg.wordpress.com/2010/12/30/how-to-connect-to-cisco-devices-via-serial-port-using-gnulinux/
原文标题:How To Connect To Cisco Devices Via Serial Port Using GNU/Linux

Filed under: Linux, SysAdmin — acidborg @ 10:17
Description: to connect your computer to a Cisco device via its console port, you usually need a RJ45 rolled cable. You can use a RJ-45 to DB-9 Female if your computer has a serial port.

RJ-45 to DB-9 Female

To communicate through the serial port with the Cisco device, you need Minicom, a terminal emulator software.

[...]

]]>
0 http://www.kvm.la/1068.html#comments http://www.kvm.la/feed/1068.html
RouterOS软路由常用命令 http://www.kvm.la/1066.html http://www.kvm.la/1066.html Fri, 25 Jan 2019 12:43:00 +0000 YY.K 修改用户密码

[admin@MikroTik]>/user                               #进入操作路径
[admin@MikroTik]/user>print                           #显示RouterOS用户
[admin@MikroTik]/user>set admin password=123456        #修改admin用户密码为123456
[admin@MikroTik] /user> /                              #返回根目录

在当前用户下修改密码

[admin@MikroTik]>password                             #修改本目录用户密码备份命令

[...]

]]>
0 http://www.kvm.la/1066.html#comments http://www.kvm.la/feed/1066.html
dd安装Routeros http://www.kvm.la/1065.html http://www.kvm.la/1065.html Sun, 20 Jan 2019 16:55:00 +0000 YY.K

wget http://download2.mikrotik.com/routeros/6.43.8/chr-6.43.8.img.zip -O chr.img.zip && \

gunzip -c chr.img.zip > chr.img && \

mount -o loop,offset=33554944 chr.img /mnt && \

ADDRESS0=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && \

GATEWAY0=`ip route list | grep default | cut -d' ' -f 3` && \

echo "/ip address add address=$ADDRESS0 interface=[/interface ethernet find where name=ether1]

/ip route add gateway=$GATEWAY0

" > /mnt/rw/autorun.scr && \

umount /mnt && \

echo u > /proc/sysrq-trigger && \

dd if=chr.img bs=1024 of=/dev/vda && \

reboot

]]>
2 http://www.kvm.la/1065.html#comments http://www.kvm.la/feed/1065.html
CentOS7重新生成 /boot/grub2/grub.cfg http://www.kvm.la/1064.html http://www.kvm.la/1064.html Sun, 20 Jan 2019 16:54:00 +0000 YY.K 修改/etc/default/grub

GRUB_CMDLINE_LINUX="rd.lvm.lv=centos/swap vconsole.font=latarcyrheb-sun16 rd.lvm.lv=centos/root crashkernel=auto vconsole.keymap=us rhgb quiet"

GRUB_CMDLINE_LINUX="rd.lvm.lv=centos/swap vconsole.font=latarcyrheb-sun16 rd.lvm.lv=centos/root crashkernel=auto enforcing=0 vconsole.keymap=us rhgb quiet"

添加 enforcing=0 或者net.ifnames=0 biosdevname=0

GRUB_DISABLE_LINUX_UUID=true

存盘退出

执行 grub2-mkconfig --output /boot/grub2/grub.cfg



]]>
0 http://www.kvm.la/1064.html#comments http://www.kvm.la/feed/1064.html
MacOS修改单个应用程序默认语言 http://www.kvm.la/1063.html http://www.kvm.la/1063.html Tue, 15 Jan 2019 19:13:00 +0000 YY.K 背景

Mac系统语言设置的是英文,安装的Office语言默认也是英文。由于习惯了中文Office的使用,想把Office的语言设置成中文,    
方法之一就是直接修改系统的默认语言设置,但并不希望直接修改系统语言,仅想修改Office软件的默认语言

实现

1获取App的Bundle Identifier

Bundle Identifier是应用软件的标识,以Microsoft Word为例,Terminal中输入命令:

mdls -name kMDItemCFBundleIdentifier /Applications/Microsoft\ Word.app

2得到结果:

kMDItemCFBundleIdentifier = "com.microsoft.Word"

3修改应用程序默认语言

该操作需要用到第一步查到的应用程序Bundle Identifier,本例中是com.microsoft.Word,Terminal中输入命令:

defaults write com.microsoft.Word AppleLanguages '("zh_CN")'

[...]

]]>
0 http://www.kvm.la/1063.html#comments http://www.kvm.la/feed/1063.html